Discussion:
SOGo won't load pages after login
(too old to reply)
k***@icloud.com
2015-03-30 15:11:37 UTC
Permalink
New issue which sprung up after changing our internet provider and doing
server updates Friday.
I am running SOGo with what I believe are the latest updates from the inverse
repository.
Server is Ubuntu 12.04.5 completely updated. Original install was with
iRedMail.8.5 and mysql for the database. We have been running live about 2
years or so.

New problem is that the new static IP pulls up the login page. When I login
(or any of my people) it just sits there loading. Looking at /var/log/sogo/
sogo.log shows the following: (domains sanitized)

Mar 30 10:51:05 sogod [2310]: 192.168.1.1 "GET /SOGo/***@xxx.local HTTP/1.1"
302 0/0 0.002 - - 0
Mar 30 10:51:05 sogod [2310]: 192.168.1.1 "GET /SOGo/***@xxx.local/view
HTTP/1.1" 302 0/0 0.003 - - 0
Mar 30 10:54:39 sogod [2310]: SOGoRootPage successful login from
'192.168.1.46' for user '***@xxx.local' - expire = -1 grace = -1
Mar 30 10:54:39 sogod [2310]: 192.168.1.46 "POST /SOGo/connect HTTP/1.1" 200
27/71 0.063 - - 0
Mar 30 10:54:39 sogod [2310]: 192.168.1.46 "GET /SOGo/xxx.local HTTP/1.1" 302
0/0 0.002 - - 0
Mar 30 10:54:39 sogod [2310]: 192.168.1.46 "GET /SOGo/xxx.local/view HTTP/1.1"
302 0/0 0.002 - - 0
Mar 30 10:54:48 sogod [2310]: SOGoRootPage successful login from
'192.168.1.46' for user '***@xxx.local' - expire = -1 grace = -1
Mar 30 10:54:48 sogod [2310]: 192.168.1.46 "POST /SOGo/connect HTTP/1.1" 200
27/71 0.039 - - 0
Mar 30 10:54:48 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local HTTP/1.1"
302 0/0 0.002 - - 0
Mar 30 10:54:48 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local/view
HTTP/1.1" 302 0/0 0.002 - - 0
Mar 30 10:54:50 sogod [2310]: SOGoRootPage successful login from
'192.168.1.46' for user '***@xxx.local' - expire = -1 grace = -1
Mar 30 10:54:50 sogod [2310]: 192.168.1.46 "POST /SOGo/connect HTTP/1.1" 200
27/71 0.032 - - 0
Mar 30 10:54:50 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local HTTP/1.1"
302 0/0 0.002 - - 0
Mar 30 10:54:50 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local/view
HTTP/1.1" 302 0/0 0.002 - - 0
Mar 30 10:58:21 sogod [2310]: 192.168.1.46 "GET /SOGo/mail HTTP/1.1" 404 33/0
0.002 - - 0
Mar 30 10:58:26 sogod [2310]: 192.168.1.46 "GET /SOGo/bob HTTP/1.1" 404 32/0
0.002 - - 0
Mar 30 10:58:39 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local/view
HTTP/1.1" 302 0/0 0.002 - - 0
Mar 30 10:58:47 sogod [2310]: 192.168.1.46 "GET /SOGo/bob HTTP/1.1" 404 32/0
0.002 - - 0
Mar 30 10:58:55 sogod [2310]: 192.168.1.46 "GET /SOGo/***@xxx.local/view
HTTP/1.1" 302 0/0 0.002 - - 0

So fro the log it appears I can login multiple users fine but nothing loads or
appears beyond the login screen. Everything else on the server appears to
work.
UFW is off.
I am able to login to Roudcube webmail just fine so it appears the db is
working and connecting.
I tried restarting sogod, apache2, mysqld, rebooting and just about everything
else but no joy
Any ideas?
Thanks in advance

Bob
--
***@sogo.nu
https://inverse.ca/sogo/lists
k***@icloud.com
2015-03-31 22:23:15 UTC
Permalink
OK, I solved this finally.

After changing our static IP I needed to get into /etc/apache2/conf.d/
SOGo.conf finding the following:

RequestHeader set "x-webobjects-server-port" "80"
RequestHeader set "x-webobjects-server-name" "yourhostname"
RequestHeader set "x-webobjects-server-url" "http://yourhostname"

and change the last line replaceing "http://yourhostname" with our new static
IP.

I then restarted apache2 and it came right up.

Hope this helps someone else who gets into this pickle!

Bob
--
***@sogo.nu
https://inverse.ca/sogo/lists
k***@icloud.com
2015-03-31 22:05:28 UTC
Permalink
Added information:
When web browser is pointed to the serveraddy/SOGo the login page loads. I
cannot find where it is coming from as I cannot find a link in /var/www nor
in /etc/apache2/sites-available.
Should I see a site/link/conf file entitled SOGo?

I am completely clueless at this point and any help greatly appreciated!

Thanks
Bob
--
***@sogo.nu
https://inverse.ca/sogo/lists
Continue reading on narkive:
Loading...